您现在的位置是:

在tp5基础上使用composer安装新扩展或插件easywechat

发布时间:2022-03-09作者:小灵龙来源:未知点击:58

问题描述:
   我的TP5是composer下载安装的,代码运行在一段时间后需要更改代码,就上传到SVN上。这里需要使用composer安装easywechat
composer require overtrue/wechat:~4.0 -vvv

控制台cmd报错:The "topthink/think -installer" plugin was skipped because it requires a Plugin API version ("1.0") that does not match your Composer installation ("2.1.0") 
我就 composer update就好了。

当我再次安装easywechat的时候又报错:overtrue/wechat require php >=7.0 -> your php version K5.6.40) does not satisfy that requirement.
这句话的意思是我的网站php版本太低了,可是我已经修改成7.3了啊。还是上面的提示。
好吧,继续。我使用宝塔里面的composer,点击执行。


看成果。


但是tp5原来的扩展都消失了。愁死了。



后来 我使用 svn update把服务器上的程序下载到本地后,算是补全了消失的扩展



如果帮到了您,请打赏一二!

标签: